Manual for Sim Chemistry
Kim Bolton, January 2006

For effective use of SimChemistry it is important to always remember your goals:

a. You can make passive use of SimChemistry, where you view animations
(tutorials) that others have made. These can be obtained from
www.adm.hb.se/~kib/calchem.htm

b. You can make active use of SimChemistry, where you create the animations.
This manual is for those making active use of SimChemistry.

Irrespective of whether you use SimChemistry as an active or passive learning tool,
the main aim is to obtain a qualitative, atomic level understanding of the
chemical concept being animated. It is expected that a deeper understanding can be
obtained from the active use of SimChemistry.

A secondary, more ambitious goal is to gain an atomic-level understanding of
macroscopic chemical concepts such as enthalpy, entropy and Gibbs free energy.

Note: Passive use of SimChemistry means that the computer gives the user atomic-
level insight into a chemical concept. Active use means that the user has to instruct
the computer how to animate the atomic motion to reveal a chemical concept. This
means that the user needs to understand the atomic-level chemistry before an
animation can be completed.

1. Introduction to SimChemistry

Before continuing with this manual, you need to study the tour.scw animation that
introduces SimChemistry. This should be downloaded to your computer, together
with the SimChemistry computer program, from www.simchemistry.co.uk| Once you
unzip the file that you download and click on the SimChemistry icon (see below) you
will receive instructions of how to run the introductory tour.scw.
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2. Introduction to molecular dynamics simulations (animations)

Use the ‘Help = Index’ option in SimChemistry to get a list of several concepts that
are important for creating animations. Click on the ‘About Molecular Dynamics
Simulation’ option to read about how the computer changes the positions of the atoms
(or molecules) over time. Of particular importance is that atoms move since they
have velocities and there are forces acting on them. These forces often come from
collisions with container walls and interactions with other atoms. These atom-atom
interactions are due to overlap of their electron clouds, and can be described in many
ways (see below). If we know the forces and velocities then each atom can be moved
(by the computer) over a short time using a mathematical equation such as:

Q(tnew)=q(tord)+vAtH(1/2m)FAt®

where (tyew) 1S the atom’s position at the new time, q(to1q) the position at the old time,
v the atom’s velocity, At=t,cw-toq 18 the time between the new and old position — also
called the time-step, m is the atom’s mass and F is the force acting on the atom. The
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computer updates the positions (and velocities) of all atoms over many time-steps, so
that one can follow the atomic dynamics over long times.

SimChemistry sets a default time-step, At, for you. It is recommended that you use
this instead of setting your own time-step, unless you are familiar with molecular
dynamics simulation methods.

3. Introduction to interatomic forces

As mentioned above, one has to describe the forces on each atom to get valid
dynamics. Use the ‘Help = Index’ option in SimChemistry and click on the
‘Interactions between Objects’ option to read about the interactions that are offered by
SimChemistry. In particular, read about

1) ‘null’ (ignoring forces between atoms),

i1) ‘mol_mol hard int’ (ignoring forces until the atoms touch, at which time
they repel each other),

111) ‘mol_mol reactive int” where atoms can react to form products when
colliding with each other

1v) ‘lennard jones_int” where Lennard-Jones (LJ) interactions are used.

Also read the link to the LJ (and mol mol reactive int if required) to understand the
four different parameters that you can set in SimChemistry to make atom-atom
interactions stronger or weaker.

Note: It is strongly recommended that you limit the well-depth, ‘e’ or ¢, in the LJ to
be less than 50. Using stronger forces may lead to numerical problems when updating
the atomic positions. Also note that the equilibrium distance between any two atoms
is the ‘s’ value that you choose in SimChemistry (i.e., s=2"%s, where o is the LJ
parameter).

Since we are using forces much smaller than in reality, we cannot expect to get
animations that are quantitatively correct (e.g., we cannot expect to get exact reaction
rates at the simulated temperatures). Hence, we limit our learning to qualitative
understanding of concepts, i.e., the way molecules move (dynamics), how the
movement changes with changes in temperature and pressure, and the
mechanisms by which molecules interact with each other.

Also remember that atoms can interact elastically or thermally with walls and pistons.
Elastic collisions means that there is no energy transferred between the wall and the
atom during the collision, and thermal collisions are when atoms get the same
temperature as the wall during the collision.

4. A simple tutorial: animating four molecules in a box.

It is easier to use SimChemistry and to understand this tutorial if you can read file
extensions on your computer (e.g., ‘.doc’ for Word files, ‘.pdf’ for pdf files, ‘.txt’ for
text files, ’.scw’ for SimChemistry files, etc.). If you cannot see these go to Start =
Settings = Control Panel = Folder Options = File Types. Choose ‘SCW’ from the
list, choose ‘Advanced’ and click in ‘Always show extension’. Do the same for TXT
(text) documents. This procedure may differ between different versions of Windows,
but is similar to this description.



5)

6)

7)

8)

9)

Go to the directory where you unzipped SimChemistry (after downloading
from www.simchemistry.co.uk) and double click on the SimChemistry icon.
Click ‘OK’ on the title and welcome pop-ups.

Make sure that the record button (the red circle in the control panel) is on.
Choose ‘Simulation = Insert Script Delay’ and choose 700. When we run the
simulation, it will be delayed by 700 s at this stage. We can always make this
0 s later, and it will help us when editing the animation (discussed below).
Click on ‘OK’ to remove the pop-up.

Choose ‘Object > New Type Of = Textbox’. We can leave the name of this
textbox as ‘textbox1’ as suggested. You can see that we can choose the font.
Click on the ‘Edit Font’, and leave the defaults ‘Arial’, ‘Normal’ and ‘12’ (or
what they are on your computer). Click ‘OK’ twice to close the pop-ups.
Choose ‘Simulation = Insert Script Delay’ and choose 8. As before, when we
run the simulation, it will be delayed by 8 s at this stage.

Choose ‘Object > Type Properties’ and you will see ‘textbox1’. This is the
textbox that we have created. Nothing else appears under ‘Type Properties’
since we have not created anything else. Once we create them they will also
appear here. Click on textbox1 to view the properties and then ‘OK’ to close
the pop-up.

Choose ‘Object - Draw —> textbox1’. Now we can insert the relevant text.
Type in ‘Illustration of 4 interacting molecules’. Click ‘OK’ and drag the
marker in the SimChemistry window. You can see the (x,y) position of the
marker at the bottom left corner of the window. Place the marker at
(x,y)=(0.9;2.3). Left-click to insert the text.

Choose ‘Simulation = Insert Script Delay’ and choose 9. As before, when we
run the simulation, it will be delayed by 9 s at this stage.

10) Choose ‘Object > New Type Of - Wall’. You can see that we can choose

the name of this type of wall (we can keep walll) and other parameters. Let’s
leave the collisions thermal (i.e., atoms colliding with the wall will get the
temperature of the wall) and the choice to use the current temperature (we can
change this temperature during the animation — if we had chosen a specific
temperature then the walls would always have this temperature, irrespective of
changes in system temperature). Click on ‘OK’ to remove the pop-up.

11) Choose ‘Object = Type Properties’ and you will see that ‘walll’ appears in

addition to the ‘textbox1’ that we created earlier. This is where we can change
the properties of this type of wall if we like.

12) Now let’s draw a box made up of 4 walls of type walll. Choose ‘Object >

Draw = walll’. You will see a marker on the screen and the X,y coordinates
of your marker in the bottom left corner of the SimChemistry window. You
can use these coordinates to choose exactly where to put the walls. Draw a
box with corners at (x,y) = (0.8,2); (0.8,1); (2.1;1) and (2.1,2). You start
drawing a wall by left-clicking once, and end drawing this wall by clicking a
second time. The second wall can be drawn by clicking a third and fourth
time, and similarly for the third and fourth walls. You can stop drawing by
pushing the escape button (‘Esc’) on the tangent board.

13) Choose ‘Simulation = Insert Script Delay’ and choose 10. As before, when

we run the simulation, it will be delayed by 10 s at this stage.

14) Now save the file by choosing ‘File = Save as’ and choose a file name. For

the sake of this tutorial choose ‘tutorial.scw’.
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15) Remove the simulation window by clicking on the cross (x) that is second-to-
highest on the right hand side of the SimChemistry window (do not click on
the highest cross since this will remove the SimChemistry window — if you do
this by mistake simply restart SimChemistry).

16) Open your saved file in the same way that you opened the ‘tour.scw’ (File =
Open - tutorial.scw). You will see that it opens at the end of your animation,
instead of giving you the message that ‘This animation is intended to run
automatically from its start’, as you got when running tour.scw animation.
You can see the animation from the beginning by switching off the record
button and then choosing ‘Simulation > Replay Script from Start’.

17) When the script is playing look at the bottom left hand corner of the
SimChemistry window and you will see the decrease in time that you inserted
for delay, i.e., 0.7 ns (you inserted 700 s but SimChemistry changes this to 0.7
ns for sake of consistency with the molecular motion that you will develop
later). After 0.7 ns reaches 0, there is the further delay of 0.008 ns that you
inserted (following the creation of a textbox that you do not see) and then the
text that you wrote after the 0.008 delay appears. This is followed by the
0.009 ns delay that you inserted before drawing the box and then the 0.010 ns
after the box was drawn. You can click on any key to move to the end of the
current delay. Repeat the ‘Play Script From Start” as often as you like.

18) Although one can view the animation from the beginning in this way, it is
better to have this option as the default. We can do this by using Wordpad (or
Notepad) to change the commands that we have given SimChemistry. One can
also say that we want to change the script that contains the SimChemistry
commands. Open your saved ‘tutorial.scw’ in Wordpad by finding Wordpad
on your computer and opening tutorial.scw or, if your version of Windows
allows, right clicking on tutorial.scw and choosing ‘Open with = Wordpad’.
In the former case, once you have opened Wordpad and you are looking for
the tutorial.scw file, you must change the ‘files of type’ option in Wordpad to
‘all files (*,*)’ so that you can see files of type .scw. Unless you have given a
specific address when saving tutorial.scw, it will be in the same directory as
your SimChemistry program. Once you open the tutorial.scw file (called the
script) you will see all the commands that you have given SimChemistry. You
will see (from top to bottom) that you have, for example, accepted the default
system temperature of 100 K, default gravity of 0, autorun set to 0 (turned
off), etc. This is followed by a description of the objects that you have made
(the four walls and the textbox) and this, in turn, is followed by the history of
your commands. You can see the delays that you have inserted as well as the
creation of a textbox — with text — and the four walls to form a box. (Do not be
concerned if the text font is not what you chose — we will edit this later.)

19) One can change the animation by working in the Wordpad document (the
script) and/or via the SimChemistry window. In this tutorial we will do both.
We will start by changing autorun to 1 (in Wordpad) and then choose ‘File >
Save’. Note that one cannot usually use ‘Save As’ since this creates a text file
(.txt as extension) which cannot be read by SimChemistry. We have thus
overwritten the only version of tutorial.scw that we have. (In some versions of
Windows one can save the .txt file and merely change the extension to ‘.scw’
to get a .scw file that can be read by SimChemistry. However, this is not
always the case and will not be used in this tutorial.)



20)Now return to the SimChemistry window (do not remove Wordpad). As
before, remove the previous simulation of the tutorial from the SimChemistry
window by clicking on the lower cross in the top right hand corner of the
window (do not save any changes to the tutorial!). Then open the new version
of tutorial.scw (the one with autorun set to 1). Now you will see the option of
running from the beginning, which you should accept. Also note that the
record button (red circle) is switched off when using the option to run
automatically from the start (as before you can click on any key to move to the
end of the current delay).

21) It is always good to keep the most recent version of the animation that works
so that we can start from this if we introduce errors into the script. Do this by
going to the directory where you have tutorial.scw (probably in the directory
where you downloaded SimChemistry), right click on tutorial.scw and choose
‘Copy’, right click on the white area in the window and choose ‘Paste’. This
saves as ‘Copy of tutorial.scw’.

22)Note that we can also make other changes using Wordpad. For example,
return to the script (in Wordpad), scroll down to ‘begin history’ and, after
‘delay 8;’ look for ‘change objtype textbox name "textboxl" font
"Arial" size 16;’ and change ‘size 16;’ to ‘size 24;’ (you may
have a different font than size 16, but make this change anyway). We will
now see larger text when we run the animation. In addition, change ‘delay
8;’ to ‘delay 0;’ to remove this delay (we could also have removed this
line from the script).

23) Save this script for tutorial.scw as before (i.e, overwriting the original version)
and replay to see the effect of the changes (remember that you need to click
away the previous simulation — you cannot merely start from the beginning).

24) What happens if we make an error? Go to the script in Wordpad and change
‘delay 0;’ to ‘del 0;’. Save this by overwriting the tutorial.scw (it is
okay to do this since we have a ‘Copy of tutorial.scw’ of the latest working
version). Then run the new version (remember that you need to click away the
previous simulation). You will see an error message, but it is not specific. To
see details of the error, click ‘OK’ on the pop-up, start the simulation and
choose ‘View = Command Consol’ and here you will see the script — i.e., the
list of commands. The command in green is the one that the program is
presently performing, and the one in red is the one that is causing the error
message. We can see that it is *del 0;’ so we can return to Wordpad and
correct this to *delay 0;’. Save the corrected file.

25)Now that we know how to implement and change commands in both the
SimChemistry interface and the script (Wordpad) interface, we can add and
manipulate objects in either interface. Let’s add two molecules. Since we do
not know the commands, we cannot add these directly to the script. We
therefore return to the SimChemistry window (remove the animation with the
error and open the corrected animation) and play the script until the end. Then
click on the record button so that our actions are recorded in the script.

26) Choose ‘Object = New Type Of = Molecule’. Note that we can change its
name (moleculel), mass, radius, colour etc, but we will choose the default
values. Click ‘OK’ to remove the pop-up. As before, one can also choose
‘Object = Type Properties” and you can choose ‘moleculel’ to edit the
molecule’s properties.



27) To draw two of these molecules choose ‘Object = Draw = moleculel’. We
can select how the initial velocities of the molecules will be chosen. Let us
choose ‘Thermal distribution at this temperature’ and 30K. Also leave the
random initial directions default. Since atomic velocities are very small at
30K, we expect that these atoms will initially move slowly until they collide
with the walls and get the wall temperature (which we left as the default 100
K).

28) Select ‘Start Drawing’ and draw two molecules, one at x;y=1.2;1.7 and the
other at x;y=1.6;1.5 (the coordinates can be seen in the lower left corner of the
SimChemistry window). Press ‘Esc’ to stop drawing molecules.

29) Choose ‘Simulation = Insert Script Delay’ and choose 11. As before, when
we rerun the simulation, it will be delayed by 11 s at this stage.

30) Now save the file by choosing ‘File = Save’ (i.e., overwrite tutorial.scw).

31) Since this file was changed after recording new changes in the SimChemistry
window, the ‘autorun’ has been reset to 0. Go into Wordpad and change this
option to ‘1’ as before (you need to open the new version of tutorial.scw in
Wordpad!). Save to tutorial.scw.

32) Open this new file in the SimChemistry window and run it. You will see that
the molecules do not move (even though we have instructed SimChemistry
what initial velocities to give the molecules). We now have to tell
SimChemistry to start the dynamics. Do this in the SimChemistry window by
going to the end of the simulation, start the recording (using the record button)
and then go to ‘Simulation = Start Script and Simulation’. You will see that
the molecules start to move on the screen, and at the same time you will see
the simulation time in the bottom left hand corner of the SimChemistry
window. This time is being recorded in the SimChemistry script (but the
actual movements of the particles are not being recorded). To stop the
simulation time click on ‘Simulation = Insert Script Delay’ and choose 20.
The molecules continue to move on the screen but the time that has been
recorded in the script has now stopped.

33) Now save the file by choosing ‘File = Save’ (i.e., overwrite tutorial.scw).

34) Open the new version of tutorial.scw in Wordpad to see the new commands.
Near the top of the script you will see that autorun has been reset to 0 (since
we have recorded new commands) so change this back to 1. At the end of the
script you will see the new commands that you have entered. They are the
‘run’ command, there is a ‘delay’ command containing the time that you ran
the simulation in the SimChemistry window, and the second delay of 20 s that
you inserted. When you run this version of tutorial.scw it will start the
dynamics of the two molecules and run them during both delay times (i.e., the
total time of the two delays). Now save the new version (with autorun 1)
using ‘File = Save’.

35)Before leaving Wordpad note the line ‘interaction mol mol hard int
objtypel "moleculel" objtype2 "moleculel" ;, which says that we
have accepted the default that these two molecules interact as hard spheres,
i.e., they do not interact until they collide, and then they collide as if they were
‘billiard balls’ (you can see that this is the case from the animation in the
SimChemistry window.

36) Run the new version using the SimChemistry window. You will see that the
molecules move for the sum of both delay times (see the bottom left corner of
the SimChemistry window for the delay times). Even after this time the



molecules continue to move on the screen, but nothing is being recorded in the
command file (i.e., in the script).

37) Copy this latest version of tutorial.scw since it works, and we can always start
from it if our future actions introduce errors that we cannot fix into the script.
(Do this by going to the directory where you have tutorial.scw, right click on
tutorial.scw and choose ‘Copy’, right click on the white area in the window
and choose ‘Paste’. This saves as ‘Copy (2) of tutorial.scw’.

38)In the SimChemistry window (where the molecules are still moving) do
‘Simulation - Run Simulation’ (i.e., we are switching off the ‘Run
Simulation’). The molecules will stop moving. Then go to ‘Object >
Interactions’ and you will see, in agreement with what we read in the script,
that the interactions between ‘moleculel’ and ‘moleculel’ (i.e., two molecules
of the type moleculel) is hard sphere. We can adjust this here if we want to,
but we will leave it unchanged in this tutorial. Also click on arrow on the
right hand side of ‘First object: moleculel’ and choose ‘walll’. You will see
(e.g., in the description box) that we have chosen that molecules of type
moleculel interact with walls of type walll by getting the wall temperature
during the collision.

39) We will now create two new molecules. Click away the ‘interactions’ pop-up,
make sure that you are at the end of the animation, and switch on the record
button. Choose ‘Object 2 New Type Of 2 Molecule’. Let’s keep the default
name of molecules of this type (molecule2), but change the radius to 0.1 nm
and the fill colour to yellow. Click ‘OK’ to remove the pop-up. As before,
one can also choose ‘Object > Type Properties’ and you can choose
‘molecule2’ to edit the properties of molecules of this type.

40) Now go to ‘Object = Interactions’, select both the first and second object as
‘molecule2’, and you will see that two molecules of this type interact as the
default hard spheres. Change this by choosing ‘lennard jones int’ (Lennard-
Jones interactions) and then ‘Make Selection Active’. You will see that we
are given default options for all parameters (see their meaning in Section 3
above). In particular, note that the default equilibrium (zero interaction force)
separation, s, is twice the radius. This does not have to be the case, but it is
the default so that the animation looks nice (i.e., at the equilibrium separation
the two circles on the screen touch each other exactly). Let us also change the
interaction strength between molecules of this type to e=10 kJ /mol. Click
‘OK’ to accept these changes.

41) In the ‘Object = Interactions’ pop-up (select this again if you clicked it away)
select the ‘First Object’ as ‘molecule2’ and the ‘Second Object’ as
‘moleculel’ (it does not matter if you choice ‘First Object’ as ‘moleculel’ and
the ‘Second Object’ as ‘molecule2’). Change the hard sphere default by
choosing ‘lennard jones int’ (Lennard Jones interactions) and then ‘Make
Selection Active’. You will see that we are given default options for all
parameters, with the default equilibrium separation, s, between a molecule of
type moleculel (radius 0.07nm) and a molecule of type molecule2 (radius 0.1
nm) being the sum of these radii. Once again, this is to make the animation
look nice. Leave the interaction strength between molecules of types
moleculel and molecule2 as e=1 kJ /mol. Click ‘OK’ to accept these changes.
Click ‘OK’ to close the interactions pop-up.

42)Note: We expect that two molecules of type moleculel to have no interactions
until they collide (hard sphere), two molecules of type molecule2 will have



strong interactions, and a molecule of type moleculel and one of type
molecule2 will have weaker interactions. We are not learning chemistry from
the computer in a passive way, but are instructing the computer what to do to
give the desired chemistry. We expect that our animations will show that
molecules of type molecule2 will group more strongly together than a
molecule of type moleculel with one of type molecule2, and that that
molecules of type moleculel will show no preference to group to each other
(but should be attracted to molecules of type molecule2).

43)To draw two molecules of type molecule2 choose ‘Object = Draw =
molecule2’. Choose ‘Thermal distribution at this temperature’ and 10K. Also
leave the random initial directions default. Since atomic velocities are very
small at 10K, we expect that these atoms will initially move slowly until they
collide with the walls (at 100 K) or with the other molecules.

44) Select ‘Start Drawing’ and draw two molecules, well separated from the two
molecules (type moleculel) that already appear and trying to set the new
molecules at their equilibrium separation (i.e., with the circles exactly
touching). Press ‘Esc’ to stop drawing molecules. Since the new (yellow)
molecules are well separated from the older (pink) molecules they do not have
any interaction at the beginning of the simulation. Also, since the yellow
molecules are separated from each other by the equilibrium distance, the force
that they will exert on each other will be close to zero.

45) Note that, although you have separated the yellow molecules from the pink
molecules, there is NO guarantee that this will be that case when you replay
the animation — that is, when replaying the animation the ‘pink’ molecules
may overlap the yellow ones and hence repel them very strongly — you will
see this as an ‘explosion’ that will take several molecule-wall collisions to
restore to the desired temperature. We could have avoided this problem by
removing the existing pink molecules (Object = Delete All of Type >
moleculel) and then redrawing two new molecules of type moleculel.

46) Start the dynamics using ‘Simulation = Start Script and Simulation’. You
will see that the molecules start to move on the screen and, as before, the
simulation time in the bottom left hand corner of the SimChemistry window is
being recorded in the SimChemistry script. You will also note that, as
expected, the yellow molecules — type molecule2 — are rather strongly bound
(large ‘e’), there is weaker attraction between pink and yellow molecules and
no attraction between pink molecules. We have understood — and taught the
computer — that the atomic-level reason why certain particles group together
and others do not is due to the interaction strengths!

47) Choose ‘Simulation = Insert Script Delay’ and choose 25. As before, when
we rerun the simulation, it will be delayed by 25 s at this stage.

48) Choose ‘Simulation = Run Simulation’ (i.e., we are switching off the ‘Run
Simulation’). The molecules stop moving on the screen and you have told the
command script to stop moving the molecules after the above delay time of 25
s (i.e., when you replay the animation it will end by stopping the molecular
motion).

49) Now save the file by choosing ‘File = Save’.

50) Open the new version of tutorial.scw in Wordpad to see the new commands.
Near the top of the script you will see that autorun has been reset to 0 so
change this back to 1. At the end of the script you will see the new commands
that you have entered, including the ‘delay’ while you were watching the



molecules move, the 25 s delay that you inserted, the delay between this
insertion and your stopping the simulation, and the ‘stop’ command that stops
the motion of the molecules when playing the animation). You can change the
Lennard Jones interaction strengths, or any other parameters, in the script
(using Wordpad) or in the SimChemistry window (as discussed above). Now
save the new version (with autorun 1) using ‘File = Save’.

51) Run the new version using the SimChemistry window several times. Note that

you get different dynamics each time, since the initial velocities and directions
of all atoms are chosen randomly (from the specified temperature). In
addition, you may be animating for different times if you are quickly moving
to the end of current delays (by pressing keys on the tangent board).

Tips for simulations

1.

Have a good idea of what you are going to simulate but be flexible to changes
Perform qualitative simulations — i.e., real experiments occur in seconds or
minutes with moles of molecules. Real attractive forces are also larger than
those that you will use in SimChemistry. Hence, do not expect things to melt
or boil at temperatures that are quantitatively correct, it is the qualitative
chemistry (how things melt or boil) that is of interest!

Be patient in the beginning. Once you learn how SimChemistry works things
go far quicker.

Save OFTEN so that you do not have to restart from the beginning if you
make an error.

Remember to start the ‘record’ button when extending existing script
programs

Use Wordpad to change the autorun option.

List of bugs
a) Sometimes the colour and font that you choose for the text does not work.

You can change font and colour using Wordpad.
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